United States
FAST DELIVERY ∙ EXPERT TECH SUPPORT
UK STOCK ∙ 2 YEAR WARRANTY
Zidoo Z9X Pro
Ultra-HD 4K Dolby Vision Home Theatre Media Player.
  INCLUDES EXPRESS 2-4 DAY DELIVERY 

Author Topic: Neo S not playing videos  (Read 977 times)

wickedguy

  • Newbie
  • *
  • Posts: 3
    • View Profile
Neo S not playing videos
« on: August 14, 2023, 11:33:11 PM »
Getting extremely frustrated with the Neo S as some videos play fine while others not at all.

I copied all of my dvd's/BluRays to .iso files. When I select a video - for example, The Revenant the pertinent video information appears  with a screen showing the details of the video, Rotten Tomatoes score, etc. (unfortunately the "Insert Image" option doesn't appear to work here). When I hit play an image of the video appears on the screen, then immediately disappears. If I hit the "Play" button again, the video details are shown, in this case the file is H.265 (ISO). Hitting it again an error appears "Unable to play video".

There appears to me to be no rhyme or reason to why some videos play while others don't.
Same thing also happens with music videos - some play fine while others not at all.

Another issue is some of the information - particularly re: the music videos is totally unrelated to the actual music video. That is the name and album cover are not at all the same as the actual music video and I haven't found any way to substitute the correct name or album cover.

Any suggestions would be appreciated.

futeko.com

  • Administrator
  • Senior Member
  • *****
  • Posts: 4626
    • View Profile
Re: Neo S not playing videos
« Reply #1 on: August 15, 2023, 12:04:19 PM »
Please post a mediainfo report on the video that won't play.

https://mediaarea.net/en/MediaInfo

 

DELIVERY ∙ PAYMENT ∙ WARRANTY+RETURNS ∙ ABOUT ∙ PRIVACY ∙ FORUM ∙ CONTACT ∙ COMPARE AUDIO STREAMERS
© SDHDIGITAL LTD 2024