FREE+FAST WORLD SHIPPING
UK STOCK   2 YEAR WARRANTY
MEDIA BOX  :  FORUM  :  CONTACT
HiMedia S500
New HiMedia HiSilicon media box running Google Certified Android TV 9.0. Imprex 2.0 image enhancement. Bluetooth voice remote.

Author Topic: HDMI CEC problem  (Read 500 times)

muzafferg

  • Newbie
  • *
  • Posts: 2
    • View Profile
HDMI CEC problem
« on: November 01, 2019, 11:10:01 AM »
HDMI CEC function is not working in my Zidoo X20 pro. I had zidoo X10 before and it was working perfectly. Now, I made the same settings in zidoo X20 pro and the other devices AV receiver+ TV. Is there any suggestions to check ?

tried almost all possible configurations but still not working. Also changed the original HDMI cable with new one but the result is the same.

Purchased the X20 pro when 2.2.61 was released and I have the same problem from the beginning. when the X20 pro gets the signal from other devices, it puts itself to the stand-by position but not opened.

Is there anybody having the same problem or give any suggestion to me?

futeko.com

  • Administrator
  • Senior Member
  • *****
  • Posts: 4192
    • View Profile
Re: HDMI CEC problem
« Reply #1 on: November 01, 2019, 05:06:45 PM »
The CEC settings are at Settings - About - Advanced Settings - HDMI CEC Functions. Obviously, it should be turned on.

Apart from that CEC can just be difficult to get set up and has flaky compatibility (not just Zidoo - all CEC devices). I would recommend powering everything off, disconnect all HDMI cables then reconnecting them one by one TV first. This should reset CEC.

muzafferg

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: HDMI CEC problem
« Reply #2 on: November 02, 2019, 12:05:40 PM »
Thank you for your reply. Tried but nothing changed.

 

DELIVERY  :  WARRANTY / RETURNS  :  FAQ  :  BREXIT  :  ABOUT
Price in £GBP with conversion by Paypal (more info). UK+EU delivery includes VAT at 20% (more info). Privacy Policy. © SDHDIGITAL LTD 2019