UK BASED. All stock shipped from Manchester, UK.
FREE+FAST
WORLDWIDE SHIPPING
FROM THE UK
2 year warranty
Expert forum based technical support
No hidden taxes UK/EU
FEATURED   MEDIA BOX   BUNDLES   OTHER   COMPARE
CART   FORUM   CONTACT
HiMedia Q10 Pro
ULTRA-HD 4K HDR
ANDROID 7
3.5" HDD BAY
LATEST OCT-2017 FIRMWARE

Author Topic: Cannot install Kodi 17  (Read 2453 times)

barza

  • Newbie
  • *
  • Posts: 4
    • View Profile
Cannot install Kodi 17
« on: February 12, 2017, 08:18:00 AM »
I have a Q5 and am trying to install Kodi 17. Running the CS 3.0.4 firmware.

Kodi is shown as not compatible with the device in Google play store, so can not install/update from there.

When I try to side load the apk, I get a 'cannot parse file' error, even though the ability to install apps from unknown sources is on in settings.

Any ideas?

Thanks in advance.

barza

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Cannot install Kodi 17
« Reply #1 on: February 12, 2017, 09:45:04 AM »
So it seems Kodi 17 requires Android 5.1 or higher, and there is no intention from the official developers to produce a version compatible with Android 4.4

The other way round this is hence for Himedia to offer an update of the 2014 Q5 to Android 5.1 or above? Is there any chance of that happening?

futeko.com

  • Administrator
  • Senior Member
  • *****
  • Posts: 3505
    • View Profile
Re: Cannot install Kodi 17
« Reply #2 on: February 13, 2017, 10:49:06 AM »
Q5/Q10 4K3D won't be updated to Android 5.1.

It's very irritating that Kodi are not supporting Android 4.4. They've done it intentionally to try and hurt the fully loaded box sellers, but it risks alienating the users that have made them what they are.

I actually expected someone to have modified Kodi 17 to get it running on 4.4 by now. I still think something like that will end up happening.

barza

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Cannot install Kodi 17
« Reply #3 on: February 16, 2017, 09:18:48 AM »
Futeko - Thanks for the reply.

You state that this device won't be updated to Android 5.1.

Can I ask (a) how you know that to be the case, and (b) why is that the case?

I suspect you are going to say that the manufacturer of the Hisilicon chipset is not going to release an updated Android kernel for Himedia to work with. But if that is true, it makes me very nervous about buying Himedia products. This matters to me as I already also own a Q5 pro, and have a Q10 pro pre-ordered from you.

Up until now, i have been quite impressed with himedia's product support. You don't need me to tell you how terrible the manufacturer provided support for most android boxes is. I even sent a drive full of 3D ISOs to Himedia to help them troubleshoot their 3D MVC solution. So I am surprised that, in this situation, Himedia would not pressure the chipset manufacturer into providing the 5.1 android update.

I note that other Andoid 4.4 devices (Tronsmart R28 as just one example), have had a 5.1 version provided, even if only given beta status.

futeko.com

  • Administrator
  • Senior Member
  • *****
  • Posts: 3505
    • View Profile
Re: Cannot install Kodi 17
« Reply #4 on: February 16, 2017, 10:26:39 AM »
HiMedia say they have no plan to upgrade 4K3D models to a more recent version of Android. I don't know the reasoning behind this.

It's unusual for Android boxes to be upgraded to a more recent Android version. Q5/Q10 Pro being an exception with their recent Android 7 update.



barza

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Cannot install Kodi 17
« Reply #5 on: February 16, 2017, 10:37:43 AM »
Is there any way you could get Himedia to reconsider that decision (if indeed it has been finally decided)?

You seem to have some degree of leverage with them as a preferred distributor of their products.

Rob

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: Cannot install Kodi 17
« Reply #6 on: April 19, 2017, 03:26:08 PM »

Loulou

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: Cannot install Kodi 17
« Reply #7 on: August 16, 2017, 03:40:45 PM »

kairi033

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: Cannot install Kodi 17
« Reply #8 on: September 16, 2017, 08:57:34 AM »
the only problem on this fork version is there is no audio passthrough option (menu) though expert menu is already toggled on and sync playback is already off under display menu  (or am I missing something) and you cannot use this version with wrapper to use your built in media player. For all the expert out there just let me know if I am missing something.

Edit : I copied the playercorefactory.xml (wrapper) from my official kodi to the user folder of mygica media center and I can vouch that it's properly working (himedia player) with audio hd passthrough. I also experimented, installed this fork to my smartphone (OPT3) and to my surprise audio passthrough option is present with the following options to toggle on and off;
-dolby digital capable receiver
-dolby transcoding
-dts capable receiver
-dolby eac3
-dolby hd
-dts-ma hd
but in himedia even a switch to turn this on and off is not there. can someone teach me how to post a pic here so I can post a screenshot of my phone and himedia.

Thanks
« Last Edit: September 20, 2017, 02:09:40 PM by kairi033 »

 

DELIVERY      WARRANTY      RETURNS      FAQ      BREXIT      ABOUT      CONTACT      
PayPal Acceptance Mark
Prices are charged in £GBP with conversion at Paypal's current rate. The Euro / $USD price on our site is approximate. More info here.
Cookie Policy. Prices for UK + EU delivery include VAT at 20%. © SDHDIGITAL LTD 2017. All rights reserved.